Workspaces

Workspaces designed to help you organize your working places and have several working sets, optimized, for example, for viewing of the source code in Windows Explorer, working with your web site, your logs or trace files.

Workspace combines current windows positions, open files, shown panels and bars, recent files, input history, current project etc. You can configure what should be stored or not in Workspace Properties dialog, available in File→Workspace→Properties.

You can save workspace to load it after; you can pass desired workspace as command line parameter when loading HippoEDIT (hippoedit.exe –workspace=viewer), you can select what should be stored in the current workspace and what not.

You can save or load workspaces using Open and Save As… commands, that can be found in main menu File → Workspace → Open / Save as….

Workspaces stored as separated xml files in workspaces directory and can be transported together with installation of HippoEDIT. So, this makes HippoEDIT completely portable, because no anymore settings are stored in the windows registry.

HippoEDIT allows you to have as standard, explicit workspaces as automatic, implicit, folder related, workspaces, which depends from current directory in time when HippoEDIT was started.

If you start HippoEDIT with workspace, that not yet exist, or could not be found, application would ask you about template for new workspace.
It can be:

  • New – creates empty workspace,
  • Copy Default – copies Default workspace,
  • Copy From…- copies workspace form existing one.

HippoEDIT comes with two pre-configured workspaces Default, loaded by default, when you start application without any workspace specified from start menu or command line, and Viewer, used when appication called from Windows Explorer by double click (hippoedit.exe –workspace=viewer) and optimized for viewing files (no panels, recent history not stored, no open files etc).

You can set by you own, which workspace should be used as default and which as viewer in Tools→Options→General→Workspace dialog. In addition there you can define default catalog, where new workspaces are stored, and from which workspaces for default and viewer boxes are loaded.

File Association dialog associate HippoEDIT with files using Viewer workspace.

If you start HippoEDIT with different workspaces, flag Allow Multiple Instances is ignored.